Discussion:
[jruby-dev] Fix for jruby-debug
(too old to reply)
Chris Seaton
2014-02-18 01:59:07 UTC
Permalink
jruby-debug doesn't work for me - I see the same error these people were
asking about in https://www.ruby-forum.com/topic/3636709. I see it when I
try to set any breakpoint.

The fix seems obvious - lnums_for_str expects some kind of Enumerable, and
we pass it a String. If we remove the join it works again.

https://github.com/jruby/jruby-debug/commit/729d242d4c255f0391eb979afd9fe3d5a5050f4a

I tried really hard to go back through the history of these libraries that
have been copy and pasted and patched, but all I find now is dead ends and
broken RubyForge repos, so I'm not sure where the canonical project for
some of these files is now to get an updated version. All I know is the
debugger doesn't work for me without this fix, and it does with it. Perhaps
at some point we updated one file but not another.

I was intending to make this fix a PR, but I forgot I had the commit bit so
when I edited it on GitHub it committed it straight away and I didn't have
the chance.

Are there people using jruby-debug at the moment? How is it working for
them? The code make no sense without this fix.

Chris

Loading...